// AI threat desk · 28 Oct 2026
Home/CVE · Vulns & Patches
Vulns & PatchesHighPHPCVSS not assigned

PHP flaws could run code after CISA added two CVEs to KEV

CISA added CVE-2026-109618 and CVE-2026-109619 to its KEV Catalog on Oct. 26, 2026, citing unauthenticated remote code execution in PHP.

AI-generated image of security analysts monitoring vulnerability alerts beside network equipment.
AI-generated image, not a photo of the event.
Key takeaways
  • CISA added CVE-2026-109618 and CVE-2026-109619 to its KEV Catalog on Oct. 26, 2026.
  • The php2shell vulnerabilities allow unauthenticated remote code execution in PHP.
  • Affected PHP installations include Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP and LiteSpeed.

CISA.gov/news-events/alerts/2026/10/21/critical-vulnerabilities-php-require-immediate-patching) added two PHP vulnerabilities to its Known Exploited Vulnerabilities Catalog on Oct. 26, 2026. The agency identified CVE-2026-109618 as a memory corruption flaw and CVE-2026-109619 as a stale internal request-state flaw.

The Record reported that CISA confirmed two PHP vulnerabilities are being targeted, and that dozens of cybersecurity and tech companies reported thousands of failed attempts to use the bugs in attacks. PHP is used to build and run web applications and the vast majority of websites, and some estimates cited by the publication put its use at more than 70% of websites on the internet.

On this page

PHP web requests expose installations to php2shell

CISA described CVE-2026-109618 as a PHP memory corruption vulnerability and CVE-2026-109619 as a PHP stale internal request-state vulnerability. CISA said the php2shell vulnerabilities allow unauthenticated remote code execution in PHP.

The affected deployment types cover PHP installations that serve web requests. CISA specifically listed Apache with mod_php, which it said PHP considers its highest-risk configuration, as well as PHP-FPM, php-cgi, FrankenPHP and LiteSpeed.

CISA listed PHP updates and monitoring steps

CISA said organizations should “immediately update” PHP to 8.5.12, 8.4.27, 8.3.36 or 8.2.35. It also told defenders to identify and inventory systems running any PHP version across their organizations.

For systems that cannot be updated, or that still use unsupported PHP 8.1 or earlier, CISA said organizations should take PHP-based systems offline until they can be patched or updated. A web application firewall may provide some protection while updates are pending.

CISA also told defenders to monitor for PHP worker processes launching shells or downloading tools. The Record reported that Sophos and Palo Alto Networks posted and then retracted claims of successful exploitation, while several experts found ways to exploit the bugs by Oct. 25, 2026.

CISA said federal civilian agencies must prioritize rapid remediation of KEV vulnerabilities on publicly exposed assets that grant total control after exploitation. The agency also said these types of vulnerabilities are a frequent attack vector for malicious cyber actors and pose significant risks to the federal enterprise.

The Record reported that CISA declined to answer questions about the nature of the exploitation or potential victims. Censys reported that more than 10 million of 42 million internet-facing PHP services had been patched since Oct. 21.

What to do now

  1. Update PHP to versions 8.5.12, 8.4.27, 8.3.36 or 8.2.35.
  2. Monitor for suspicious activity, including PHP worker processes launching shells or downloading tools.
  3. Take PHP-based systems offline if you cannot update immediately or continue to use PHP 8.1 or earlier unsupported versions.

FAQ

What happened to PHP on Oct. 26, 2026?

CISA added CVE-2026-109618 and CVE-2026-109619 to its Known Exploited Vulnerabilities Catalog.

What can the php2shell PHP vulnerabilities do?

CISA said the vulnerabilities allow unauthenticated remote code execution in PHP.

Which PHP installations are affected?

The affected installations serve web requests and include Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP and LiteSpeed.

Which PHP versions fix CVE-2026-109618 and CVE-2026-109619?

CISA told organizations to update to PHP 8.5.12, 8.4.27, 8.3.36 or 8.2.35.

What should organizations using unsupported PHP do?

CISA said organizations using PHP 8.1 or earlier, or those unable to update, should take PHP-based systems offline until they can be patched or updated.

Sources

  1. Critical Vulnerabilities in PHP Require Immediate Patching | CISA, CISAPrimary
  2. CISA Adds Two Known Exploited Vulnerabilities to Catalog | CISA, CISAPrimary
  3. CISA warns of PHP bug exploitation attempts, gives federal agencies days to patch, The Record
How we checked this story
ClaimSourceStatus
CISA said it updated its PHP alert on October 26, 2026, after adding CVE-2026-109618 and CVE-2026-109619 to the KEV Catalog.CISAConfirmed
CISA said the vulnerabilities, known as php2shell, allow unauthenticated remote code execution in PHP.CISAConfirmed
CISA said the vulnerabilities affect PHP installations serving web requests, including Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP and LiteSpeed.CISAConfirmed
CISA told organizations to identify and inventory systems running any PHP version.CISAConfirmed
The Record reported that CISA confirmed the two PHP vulnerabilities were being targeted.The RecordAttributed
CISA considers active exploitation to include both attempted and successful exploitation of vulnerabilities.CISA, via The RecordAttributed
CISA said it added CVE-2026-109618 and CVE-2026-109619 to the KEV Catalog on October 26, 2026.CISAConfirmed
CISA identified CVE-2026-109618 as a PHP memory corruption vulnerability.CISAConfirmed
CISA identified CVE-2026-109619 as a PHP stale internal request-state vulnerability.CISAConfirmed
CISA said the vulnerability types are a frequent attack vector for malicious cyber actors and pose significant risks to the federal enterprise.CISAConfirmed
CISA said federal civilian agencies must prioritize rapid remediation of KEV vulnerabilities on publicly exposed assets granting total control after exploitation.CISAConfirmed
The Record reported that Sophos and Palo Alto Networks posted and retracted claims of successful exploitation.The RecordAttributed
The Record reported that several experts discovered ways to exploit the vulnerabilities by Sunday, October 25, 2026.The RecordAttributed
The Record reported thousands of failed attempts to use the vulnerabilities in attacks.The RecordAttributed
The Record reported that CISA declined to answer questions about the exploitation or potential victims.The RecordAttributed
The Record reported that PHP builds and runs web applications and is used by the vast majority of websites.The RecordAttributed
The Record reported that some estimates put PHP usage at more than 70% of websites on the internet.The RecordAttributed
Censys reported that more than 10 million of 42 million internet-facing PHP services had been patched since October 21.Censys, via The RecordAttributed
CISA said a web application firewall may provide some protection until systems are updated or patched.CISAConfirmed
CISA published its report on Oct 26, 2026.CISAConfirmed
CISA published its report on Oct 26, 2026.CISAConfirmed

Could not verify

  • How many organizations or systems were affected is not established.
  • Whether any reported exploitation attempts compromised victims is not established.
  • Whether the two vulnerabilities have a CVSS score is not established.
Explore with AI